Audio/Visual & Electronics Wired up? Everyone's got some sort of electrical modification... let's hear about it here.

Factory Radio Issue 07 Civic LX

  #1  
Old 05-23-2019, 09:48 AM
Junior Member
Thread Starter
Join Date: May 2014
Location: Illinois
Posts: 6
Default Factory Radio Issue 07 Civic LX

My 07' Civic LX factory radio [base radio, not the special upgraded one] has been experiencing an intermittent issue lately. Every once in a while I hear a loud pop and the radio blanks out. After a few seconds the display comes back on but there is no sound until I turn the car off and back on. Then it will work normally for a few days or even a week+ before repeating the issue.

To note, my front right door speaker is completely dead. Not sure if this is just age, due to the loud pop, or what.

Has anyone else experienced this or have an idea of what the cause could be? I'm probably going to install an aftermarket head-unit in the hopes that the issue lies in the stock head-unit or amp and not somewhere more remote that would cause the same issue no matter what head-unit is installed.

Thanks in advance.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Greg Philley
Mechanical Problems & Technical Chat
0
10-31-2015 06:23 AM
mudhenFUF
Mechanical Problems & Technical Chat
5
08-21-2013 06:36 AM
racefourfun
Mechanical Problems & Technical Chat
0
11-19-2011 07:37 AM
Arrowman400
General Civic Talk
1
01-16-2008 04:20 AM
1998wagonhatch
PRIVATE For Sale / Trade Classifieds
1
07-13-2005 02:02 PM


Thread Tools
Search this Thread
Quick Reply: Factory Radio Issue 07 Civic LX


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.