Engine & Internal Chat about beefing up your engine's insides here.

Flat spot?

  #1  
Old 09-04-2007, 06:41 AM
Thread Starter
Join Date: Nov 2006
Location: Southampton - UK
Posts: 39
Default Flat spot?

I've started to notice the last couple of months that i seem to lose power between 3.5 - 4 k revs its very noticeable in second gear and feels like im letting off the power. Any ideas? I've had new plugs, leads & fuel filterrecently.It seems to be getting worse & justfeels like the whole thing is slowing down. I have tried the fuel line/injector cleaners & nothing else is out of the ordanary.The car, well its the slow one 1.5EG hatch non v-tec(think its the D15) uk spec. Thanks
 
  #2  
Old 09-04-2007, 07:14 AM
riceburner700's Avatar
Recognized HCF Member
Join Date: Jan 2005
Location: Loveland CO
Posts: 6,629
Default RE: Flat spot?

check into your o2 sensor might be going out. worth a shot
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jriehl08
Mechanical Problems & Technical Chat
4
11-18-2013 04:06 AM
silverbullet01
Inside and Out
14
10-25-2007 04:12 AM
hatch46580
The Lounge
64
05-23-2007 06:29 AM
StevieG1223
Engine & Internal
0
04-29-2007 04:48 PM
jusplayn85
The Lounge
8
04-24-2006 07:19 PM


Thread Tools
Search this Thread
Quick Reply: Flat spot?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.