Turbo'D 99 Honda Civic Si won't start! - HondaCivicForum.com

Go Back  HondaCivicForum.com > Civic Style > Engine & Internal
Reload this Page >

Turbo'D 99 Honda Civic Si won't start!

Engine & Internal Chat about beefing up your engine's insides here.

Turbo'D 99 Honda Civic Si won't start!

  #1  
Old 07-26-2016, 07:23 PM
Junior Member
Thread Starter
Join Date: Jul 2016
Posts: 1
Default Turbo'D 99 Honda Civic Si won't start!

My car roughly has 168k on it. I have BC camshafts, aem cam gears an a Turbonetics t3t4 turbo an waste gate. With Blitz BOV. Replaced Pistons an rings recently. Car has spark to wires is timid correctly but the plugs are black when I check them not dripping wet but residue will rub off on my fingers when I hold the firing end of the plug. Fuel pump works fine. Nothing is blocking the air. Car doesn't leak oil. Checked the IACV seems fine. Cleaned the throttle body. I don't have the correct tools to check the coil. But figured if the plugs had spark be ok? It's throwing misfire codes in all 4 cylinders and a vtech malfunction in bank 1. Any ideas?? Thanks in advance!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
David_S
Mechanical Problems & Technical Chat
3
10-24-2013 11:06 AM
jeff71601
Mechanical Problems & Technical Chat
14
03-02-2011 09:05 AM
BabyGangsta
Mechanical Problems & Technical Chat
4
08-04-2006 10:06 PM
eclecticanna
Mechanical Problems & Technical Chat
5
12-13-2005 11:21 PM
randocsmith
Mechanical Problems & Technical Chat
3
07-08-2005 06:53 PM


Thread Tools
Search this Thread
Quick Reply: Turbo'D 99 Honda Civic Si won't start!


Advertising
Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.