Engine & Internal Chat about beefing up your engine's insides here.

wtf is going on here

  #1  
Old 12-08-2007, 07:11 AM
HCF Member
Thread Starter
Join Date: Dec 2007
Posts: 46
Default wtf is going on here

i finaly got my cel to go away and now my temp gauge stays at cold but my upper radi hose gets real hot so hot that i end up shuting the car for fear of engine failue oh and my fans dont cut on either
 
  #2  
Old 12-08-2007, 08:09 AM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default RE: wtf is going on here

Edited:

It sounds like you possibly may not be letting your engine heat up sufficiently to trigger the radiator fan to turn ON (circuit controlled by the TW sensor). If so, then you may only be having a problem with the temperature gauge circuit, which is instead controlled by the coolant temperature sending unit.

1) Let the engine run longer to determine whether the radiator fan eventually turns ON. If fan never turns ON, then check whether fuse #13 (under dash) or fuse #33 (under hood) is blown. Also, check whether the connectors at the TW sensor may be loose. Unplug and replug them to ensure that they are making good electrical contact. If the connectors are fine, troubleshoot the radiator fan circuit (fan, relay, TW sensor).

2) Temperature gauge problem: Check whether fuse #15 (under dash) is blown. Troubleshoot the temperature sending unit and gauge itself.

 
  #3  
Old 12-08-2007, 11:33 AM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default RE: wtf is going on here

The picture shows how to test both the temperature gauge and the sending unit (the sending unit sensor appears to be located next to or near the TW sensor). Good luck with the troubleshooting.

[IMG]local://upfiles/25538/D740187697D04CE08D3B37E45D978947.jpg[/IMG]
 
  #4  
Old 12-08-2007, 12:00 PM
riceburner700's Avatar
Recognized HCF Member
Join Date: Jan 2005
Location: Loveland CO
Posts: 6,629
Default RE: wtf is going on here

sounds like your thermostat isnt opening, try replacing it and see what happens
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KidCivic
Mechanical Problems & Technical Chat
13
10-19-2007 12:30 PM
GReddy_Civic
General Civic Talk
3
06-07-2007 04:01 AM
Colby Day
Mechanical Problems & Technical Chat
5
09-25-2006 08:27 PM
blkwidow
Nitrous, Super Chargers, & Turbos
11
07-27-2006 03:03 PM
dj_ipirate
ECU Tuning & Fuel Management
4
10-18-2005 01:33 PM


Thread Tools
Search this Thread
Quick Reply: wtf is going on here


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.