vtec issues - HondaCivicForum.com


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-08-2011, 05:28 PM
Junior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 5
Default vtec issues

hello everyone i am new to this site. i have a 98 honda civic 4 dr lx, swapped the motor for a B16b about 3 yrs ago and vtec didnt work at all.. but just recently i had to getting a fake inspection for my car.

so my mechanic had some options and it was going be alot of money to make it legitly pass state inspection because i don't have a evap system and several sensors, so long story short he replaced the ecu , 600$ later vtec works it was awesome a nice boost and sick deeper exhaust kicks in at 5500 and goes to 8k but after like 20 mins of driving the vtec wont work anymore.

then car kicks back at 6500 and the car isnt as fast and it pisses me off. all i have to do to make it work is turn off the car and turn it back on then it will work again but i don't wanna do that all the time i wanna fix it .. please help give me some advice
Reply With Quote
  #2  
Old 04-11-2011, 11:26 AM
cvcrcr99's Avatar
Moderator
 
Join Date: Aug 2007
Location: DUB Caeser
Posts: 7,065
Default

Any CELs?

Vtec could be disabled for a number of reasons while driving.
Reply With Quote
  #3  
Old 04-25-2011, 02:00 PM
Junior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 5
Default

im sure it is a number of things it could be. but idk. i was thinking maybe the vtec solonoid is going but its works for like a while then it doesnt, and all i gotta do is turn the car off for a second turn it back on to make it work again. so thats why i dont think it is the vtec solonoid.

car also has a idle issue sometime kinda sounds like a miss fire but doesnt do it all the time.. my car usually idles normally at 1k-1200k but it bogs down to like 500k and wont stop until i hit the gas, but it will do it again but it will eventually clear up and the car will be fine. so maybe this has to do with it .? something with my injectors, spark plugs not hitting properly something with fuel i really dont know.

i dont want to take it to a mechanic and he will charge me 900 to fix something and its not even the probably.
Reply With Quote
  #4  
Old 04-26-2011, 08:45 AM
cvcrcr99's Avatar
Moderator
 
Join Date: Aug 2007
Location: DUB Caeser
Posts: 7,065
Default

Any Check Engine Lights (CELs)?
Reply With Quote
  #5  
Old 04-26-2011, 04:10 PM
Junior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 5
Default

oh yea but there for evap system codes and one i think is a sensor
Reply With Quote
  #6  
Old 04-27-2011, 06:59 AM
cvcrcr99's Avatar
Moderator
 
Join Date: Aug 2007
Location: DUB Caeser
Posts: 7,065
Default

You need to find out what those codes are, and then worry about your VTEC. The codes can be preventing you from switching to VTEC.
Reply With Quote
  #7  
Old 04-27-2011, 08:39 AM
Shandles's Avatar
HCF Member
 
Join Date: Sep 2005
Location: Columbia, Missouri
Posts: 1,431
Default

anytime your car is throwing a check engine light, it puts the car into "limp mode" which disables vtec.

so, get your CELs figured out, fixed and viola! VTEC!
Reply With Quote
  #8  
Old 04-27-2011, 09:38 AM
Junior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 5
Default

But how come it works for a while then stops working? Because it throws out a code 30 mins into driving to make it to stop working . And like I said all I gotta do to make it work is turn off the car then real fast turn it back so I guess that makes it reset the ecu
Reply With Quote
  #9  
Old 05-15-2011, 06:48 AM
Junior Member
Thread Starter
 
Join Date: Apr 2011
Posts: 5
Default

Okay guys I don't think my cels had to anything to do with my vtec not working all the time because I replaced my vtec solenoid and now it works all the time .. but it didn't fix how my car idles sometimes and when I first start the car and try to go , ( while I'm on the gas) my car wont move I would have to take my foot off the gas and repeat this until it goes away
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
D15B vtec, D15B(w/3-stage)vtec, or B16B type r vtec Booger EK Swaps 2 08-09-2011 11:11 PM
91 si with d15b vtec (Having issues!!!) reww Mechanical Problems & Technical Chat 6 04-19-2011 08:46 PM
VTEC issues ROFLmao Mechanical Problems & Technical Chat 7 03-11-2008 04:52 AM
11:5 LS/VTEC Issues 1quickhatch Engine & Internal 4 03-09-2007 08:25 AM
VTEC to Non-VTEC Engine Replacement kcmercedes EK Swaps 6 09-25-2004 12:05 AM


Tags
98, car, cel, civic, disabled, h22a, home, honda, limp, mode, stops, time, turn, type, vtec, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:31 PM.