Engine & Internal Chat about beefing up your engine's insides here.

O2 sensor...need help

  #1  
Old 11-05-2006, 03:43 PM
Thread Starter
Join Date: Oct 2006
Location:
Posts: 76
Default O2 sensor...need help

Hey i know that this may sound stupid but i can't the thing out. The size is like 20 or 21mm but i don't have one so i am using a 7/8" O2 sensor socket. I have tried pentrating oil, heat and a BFH but nothing will work. My car is running like crap and I need this fixed ASAP.
 
  #2  
Old 11-05-2006, 07:43 PM
Thread Starter
Join Date: Oct 2006
Location:
Posts: 76
Default RE: O2 sensor...need help

Well I got it out...only took a torch and an exhaust pipe red hot but I got it out!! But my car is still not running like normal. Is it normal for a new sensor to take a while to return to peak efficiency? Or is there something else wrong? The engine just doesn't want to accelerate...if you give it full throttle the engine just holds at like 4500rpm. Is there a fuel problem? I looked at the spark plugs and the gap is correct and everything appears to be fine. I need some help!!!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
addiction2bass
Private 'Wanted' Classifieds
1
08-14-2008 09:53 PM
fglaustin
Mechanical Problems & Technical Chat
3
03-27-2008 08:29 PM
vtec02
ECU Tuning & Fuel Management
2
05-09-2007 05:17 AM
00sithrottle
PRIVATE For Sale / Trade Classifieds
5
05-12-2005 10:25 AM


Thread Tools
Search this Thread
Quick Reply: O2 sensor...need help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.