Engine & Internal Chat about beefing up your engine's insides here.

problem with MAP sensor reading

  #1  
Old 03-14-2009, 04:21 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Dhaka, Bangladesh
Posts: 2
Default problem with MAP sensor reading

hello... i am a noob here so pls excuse any stupid questions that i may ask.

i have a B16A motor in my JDM EK Civic SiR. i have an Apexi Neo installed and i can see the MAP sensor readout there. the problem is, the PRS is never coming to 0. it comes to -6 or -5 but not to 0. i have replaced the MAP sensor but still the same thing. as a result, the car is slower and feels sluggish. but when the readout came to 0, it literally flew.

even with the ignition on only (with motor off), the readout is -6 kpa. i have rechecked the apexi neo wiring and all the settings are 100% accurate.

please help me to resolve this problem
 
  #2  
Old 03-14-2009, 05:41 AM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default

Is the CEL ON?

Do electrical troubleshooting of the wires between the MAP sensor and ECU.

It's also possible that the ECU is bad.
 
  #3  
Old 03-15-2009, 03:31 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Dhaka, Bangladesh
Posts: 2
Default

no..the CEL is not on. i double checked the wiring of the MAP sensor to the Apexi Neo to the ECU...no faults.

it may be a silly question, but if wiring prob was there, wont the CEL be on as it would detect certain readings from the MAP?? it was working fine for over a year and i didnt mess with the wiring at all
 
  #4  
Old 03-15-2009, 05:22 AM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default

Not all circuit faults will throw a CEL code. Did you test MAP sensor wires for both continuity/resistance and voltage. Isn't it also possible that the Apexi Neo is faulty?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
civicsamps
Mechanical Problems & Technical Chat
2
04-15-2010 05:05 AM
dfawcett117
Mechanical Problems & Technical Chat
8
05-13-2009 09:26 PM
asechrist
Mechanical Problems & Technical Chat
5
06-04-2008 10:33 AM
00sithrottle
PRIVATE For Sale / Trade Classifieds
5
05-12-2005 10:25 AM
red_sleeper
Nitrous, Super Chargers, & Turbos
5
01-15-2005 01:08 AM


Thread Tools
Search this Thread
Quick Reply: problem with MAP sensor reading


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.