Engine & Internal Chat about beefing up your engine's insides here.

Running hot...

  #1  
Old 07-31-2006, 02:21 PM
Thread Starter
Join Date: Jun 2006
Location:
Posts: 64
Default Running hot...

I put swapped my D15 out w/ a SOHC D15B. I also turbo'd it...(my previous motor was turbo'd and I didn't have heat issues.) I had to get my car towed home the other day, because I couldn't get my motor to cool down. I checked all the fluids and all was well. When I got home, I took my old thermostat out and replaced it. That seemed to fix it, however, When I drive on the freeway, my temperature gage goes above the half way mark. It has never done that before. What concerns me is I added an intercooler due to my turbo kit and I thought that the intercooler would take care of that. I know my fan is working just fine. Also too, what would an aftermarket/racing radiator do for me? thanks Also too, I have a brand new waterpump so I know that's not the problem.
 
  #2  
Old 07-31-2006, 02:39 PM
My04Civic's Avatar
Administrator
Join Date: Jun 2006
Posts: 4,161
Default RE: Running hot...

possibly some oil issues, check all of your fluids, its just a guess, im stumped for ya too
 
  #3  
Old 07-31-2006, 02:58 PM
HCF Member
Join Date: Jun 2006
Location: USA
Posts: 1,193
Default RE: Running hot...

If your intercooler is in front of your radiator (which it should be) then the air getting to the radiator is warmer.

I would try adding some Redline Water Wetter. Or maybe go waterless.
 
  #4  
Old 08-01-2006, 08:45 AM
burnindesirez02's Avatar
Moderator
Join Date: Jul 2006
Location: Northwest Indiana
Posts: 987
Default RE: Running hot...

I just bought an aftermarket radiator for my car because the other one had a crack on it. It works well. My temp stays way under the half way mark!!!
 
  #5  
Old 08-01-2006, 08:53 AM
Forty04's Avatar
Laced with Sarcasm
Join Date: Mar 2005
Posts: 15,279
Default RE: Running hot...

What do you have for a radiator setup right now? Specifics are good
 
  #6  
Old 08-01-2006, 02:11 PM
Thread Starter
Join Date: Jun 2006
Location:
Posts: 64
Default RE: Running hot...

My radiator is stock....I do have an intercooler
 
  #7  
Old 08-02-2006, 09:37 AM
Forty04's Avatar
Laced with Sarcasm
Join Date: Mar 2005
Posts: 15,279
Default RE: Running hot...


ORIGINAL: kbeers

My radiator is stock....I do have an intercooler
Do you have both of them in, or just one?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
general23cmp
Mechanical Problems & Technical Chat
4
12-20-2008 10:43 PM
Onejediknight
General Civic Talk
11
12-07-2007 09:07 AM
Benny
General Civic Talk
16
07-15-2007 11:07 AM
mill$civic
The Lounge
1
09-22-2006 10:33 PM
Skrapdoggydog
Nitrous, Super Chargers, & Turbos
6
07-23-2006 11:13 AM


Thread Tools
Search this Thread
Quick Reply: Running hot...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.