Header, Intake, & Exhaust Custom Exhaust? New Headers? Need Opinions on Intakes? Discuss making your ride breathe better here.

DID I DO IT RIGHT??? Installed AEM SRI 98 dx

  #1  
Old 09-03-2006, 04:16 PM
Thread Starter
Join Date: Sep 2006
Posts: 2
Default DID I DO IT RIGHT??? Installed AEM SRI 98 dx

This is my first ever performance mod purchased and installed to my 98 dx hatch, the question is did i do it right?
I felt a difference after i installed it, the thing is I HEAR a WHISTLE sound when pressing the gas pedal slightly is that ok?, after 3000rpm there's that THROATY sound which is nice.

1st I disconnected the battery terminal and the took out the stock airbox
2nd Then installed the AEM intake connected the hose and AIT Sensor
3rd Tightened all the screws and REconnect the battery
4th Then let it run for 15mins and didn't touch the gas pedal at all.

Did i do everything right Just wanted to make sure cuz its my 1st time, took me an hour.

PICS






 
  #2  
Old 09-03-2006, 04:20 PM
Senior Member
Join Date: Jul 2005
Location:
Posts: 2,501
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

Just check that your clamps are tight on the filter, throttle body, etc.
 
  #3  
Old 09-03-2006, 04:29 PM
Thread Starter
Join Date: Sep 2006
Posts: 2
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

Just check that your clamps are tight on the filter, throttle body, etc.
i triple check them already when i was done.
is the whistling sound ok , i thinks its just the point where the intake starts to sucks in air
 
  #4  
Old 09-03-2006, 04:40 PM
Join Date: Aug 2005
Location:
Posts: 992
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

yes the whistling is a good sign for intakes. i love when i hear mine while driving around.
 
  #5  
Old 09-03-2006, 04:52 PM
HCF Member
Join Date: Jun 2006
Location: USA
Posts: 1,193
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

Looks good to me.
 
  #6  
Old 09-03-2006, 11:52 PM
Join Date: Jun 2006
Location:
Posts: 611
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

yep, you're set up right. The whistle is completely normal, my buddy (who I got my dx from) liked to think it was his fake turbo spool .
 
  #7  
Old 09-04-2006, 12:24 AM
civicexracer's Avatar
Moderator
Join Date: Jul 2005
Posts: 5,802
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

did it perfectly. looks great! and im sure it sounds pretty schweet
 
  #8  
Old 09-04-2006, 02:22 AM
Peg_Leg's Avatar
Stinky Administrator
Join Date: Feb 2006
Location: Somewhere
Posts: 11,121
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

looks great nice job
 
  #9  
Old 09-04-2006, 02:25 AM
Marty's Avatar
HCF Member
Join Date: Jan 2005
Location: South Central
Posts: 8,519
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

looks fine to me.
 
  #10  
Old 09-05-2006, 12:24 AM
cyberx32's Avatar
HCF Member
Join Date: Jun 2006
Location:
Posts: 4,396
Default RE: DID I DO IT RIGHT??? Installed AEM SRI 98 dx

looks good, but i never heard about leaving it run for 15 minutes without touching the gas. When i changed mine i didnt even take off the negative from the battery (i had to do it later stupid check engine light came on) and everything worked out good.
 

Thread Tools
Search this Thread
Quick Reply: DID I DO IT RIGHT??? Installed AEM SRI 98 dx


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.