First Civic. Replaced ELD and gauges quit working - HondaCivicForum.com

Go Back  HondaCivicForum.com > Civic Style > Inside and Out
Reload this Page >

First Civic. Replaced ELD and gauges quit working

Inside and Out Talk about your interior and exterior mods here.
Sponsored by:
Sponsored by:

First Civic. Replaced ELD and gauges quit working

Reply

 
 
 
  #1  
Old 03-30-2018, 08:20 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 1
Default First Civic. Replaced ELD and gauges quit working

2001 civic lx.
So to start with, the previous owners crossed the battery cables accidentally. Replaced the 80a fuse. Driving it home, the gauges quit while I was in transit. Got home and did the gauge test (the lights on and off and trip 5 times) and the dash reset. Gauges seemed to be working but check engine on. coded to replace ELD. Replaced the ELD and now the gauges don't work at all. Still get the dummy lights. No mileage gauge (digital). it also won't respond to the gauge reset. Am I looking at replacing it or does someone have any ideas? Willing to try anything at this point.
Thanks in advance.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mharnisch
Mechanical Problems & Technical Chat
0
05-30-2012 05:08 PM
Reades98
Mechanical Problems & Technical Chat
1
08-09-2011 06:11 PM
heathepw
New Member Introductions
1
01-28-2009 12:07 PM
av3rag3am3rican
Mechanical Problems & Technical Chat
3
10-06-2007 09:33 PM
sincitycivic
Mechanical Problems & Technical Chat
4
02-21-2007 01:01 AM


Thread Tools
Search this Thread
Quick Reply: First Civic. Replaced ELD and gauges quit working


Advertising
Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.