Mechanical Problems & Technical Chat If you've got a problem you just can't figure out, a noise you can't diagnose, or a check engine light that won't go away, ask about it here!

2005 Cruise not working

  #1  
Old 02-04-2007, 06:46 AM
Thread Starter
Join Date: Feb 2007
Posts: 2
Default 2005 Cruise not working

The cruise control in my2005 Honda Civic EX Special Edition suddenly stopped working. Thecontrol light does come on when I push the dash mounted cruise button, but the cruise will not engage when the "set" button is pushed on the steering wheel. There's no reference in the manual for a cruise control fuse. Any ideas on where to start troubleshooting this?
 
  #2  
Old 02-04-2007, 11:56 PM
Eun
Eun is offline
Senior Member
Join Date: Dec 2006
Location: Santa Rosa
Posts: 786
Default RE: 2005 Cruise not working

wait, so you checked the fuse or you didn't?
 
  #3  
Old 02-05-2007, 04:27 AM
Thread Starter
Join Date: Feb 2007
Posts: 2
Default RE: 2005 Cruise not working

I can't find a fuse to check. The owner's manual doesn't list the cruise control in the fuse location charts. I don't know if this means that the cruise control shares a fuse with another circuit or if it's protected by some other method. If the cruise control is on ashared circuit, it sure wouldbe handy if Honda had listed it. The owner's manual makes noreferences to the cruise control, other than explaining how to use it.
 
  #4  
Old 02-05-2007, 04:50 AM
HCF Member
Join Date: Dec 2006
Location:
Posts: 2,459
Default RE: 2005 Cruise not working

Down by your fusebox under the left side of your steering wheel on the other side of the fusebox door I'm pretty sure there's a detailed little list of what fuse is what...
 
  #5  
Old 11-15-2007, 08:37 AM
HCF Member
Join Date: Nov 2007
Location:
Posts: 54
Default RE: 2005 Cruise not working

im having the same problem with my 2001 lx. no fuse or relay location given anywhere, but the light on the switch works, which i would assume is on the same circuit. if it was speed sensor i dont think my speedometer would work or be accurate. i need the same help!!!
 
  #6  
Old 11-15-2007, 09:25 AM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default RE: 2005 Cruise not working


ORIGINAL: sto73

im having the same problem with my 2001 lx. no fuse or relay location given anywhere, but the light on the switch works, which i would assume is on the same circuit. if it was speed sensor i dont think my speedometer would work or be accurate. i need the same help!!!
Start by checking whether fuses #4 (10A) and #10 (7.5 A) in the under-dash fuse/relay box are blown.

If the fuses are fine, troubleshoot the main and set switches as shown in the picture.

[IMG]local://upfiles/25538/4F25A574A4E44690AD40FC216E17C7B2.jpg[/IMG]
 
  #7  
Old 11-15-2007, 09:41 AM
HCF Member
Join Date: Apr 2006
Location: Idaho Falls
Posts: 2,934
Default RE: 2005 Cruise not working

RonJ you are a good man.
 
  #8  
Old 11-15-2007, 09:44 AM
Recognized HCF Member
Join Date: Jun 2007
Posts: 10,023
Default RE: 2005 Cruise not working

There are also switches on the clutch and brake pedals that will drop out the cruise when either pedal is pressed, and I would assume prevent it from being set if the switch is bad and thinks the pedal is pressed.
 
  #9  
Old 10-14-2016, 11:35 AM
Junior Member
Join Date: Oct 2016
Posts: 1
Default

Hello, I have a 2005 Honda Civic Hybrid, and I am having similar problems with my cruise control.
Your image link that you left in your last message on this thread is no longer working. It is a dead link.
[IMG]local://upfiles/25538/4F25A574A4E44690AD40FC216E17C7B2.jpg[/IMG]

my fuse is still good, the problem I am having is that the problem is intermittent and un predictable.
Sometimes it works, sometimes it doesn't. Sometimes I can correct it by pushing the cruise button on the lower dash, on and off, on and off. The intervals are longer now where it won't work at all, 2 weeks it did not work, then this morning after a rainstorm, it started working again.
Where should I look? Do you still have that picture of the main and set switches?
Thanks
 
  #10  
Old 10-18-2016, 03:44 PM
Junior Member
Join Date: Oct 2016
Posts: 2
Default

Not a fuse problem its a spring problem what i did was cut a little piece of on a gift card old credit card etc. Push the button down when you see the cruise light on the dash wedge that piece of a card in between that little space between button and wheel this should do the trick
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
apoplectic1
Mechanical Problems & Technical Chat
9
04-13-2010 05:43 AM
jamt11
Mechanical Problems & Technical Chat
2
09-05-2007 04:18 PM
dmsteele92831
Mechanical Problems & Technical Chat
5
07-23-2007 11:10 AM
chrisroug
Mechanical Problems & Technical Chat
2
10-02-2006 11:36 AM
utgtcivic
ECU Tuning & Fuel Management
4
09-09-2005 02:12 PM


Thread Tools
Search this Thread
Quick Reply: 2005 Cruise not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.