2010 Civic LX A/C stops blowing cold air after 15 minutes - HondaCivicForum.com


Mechanical Problems & Technical Chat If you've got a problem you just can't figure out, a noise you can't diagnose, or a check engine light that won't go away, ask about it here!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-20-2018, 07:52 PM
Junior Member
Thread Starter
 
Join Date: Jun 2018
Posts: 1
Default 2010 Civic LX A/C stops blowing cold air after 15 minutes

My 2010 Civic just started doing this... it stops blowing cold air after about 15 minutes of driving, but only on very hot days (temps over 85 degrees). If I keep driving and wait, after awhile, the A/C kicks back on, but it takes quite awhile for this. I have already taken it to a mechanic that I trust, and he replaced some valves that he said may have been causing a leak and recharged my a/c with refrigerant. It was still happening, so I took it back and he tried cleaning the valves again but said they were still pressurized, so he isn't sure how a leak could be coming from that area. He did say that there was a small loss of refrigerant since it was recharged last. I am hoping for some suggestions to give him if this keeps happening (I think it will). Again, this only happens on really hot days, which is extra frustrating because he can't replicate the problem when I finally get the car to him (not a hot day). Also, when the a/c kicks back on after it dies, there is a odd smell, kind of like feet. Maybe this helps. Thanks for any suggestions.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Civic EX A/C and Heat Stops Blowing Intermittently LoungeLover Mechanical Problems & Technical Chat 2 10-23-2011 10:31 PM
Heater blowing cold air after removing and replacing heater control panel tgs Mechanical Problems & Technical Chat 10 03-28-2010 07:12 PM
Cold A/C runs out after about 15 minutes of driving DeanHensler Mechanical Problems & Technical Chat 22 09-13-2009 01:40 PM
Engine makes ticking sound for 5 minutes after cold start 97Coupe Engine & Internal 13 10-22-2007 02:35 PM
horn stops working, works, then stops again vbcamry General Civic Talk 4 12-25-2006 02:19 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -8. The time now is 07:04 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.