98' DX idle surge random misfire iacv? ficv? - HondaCivicForum.com

Go Back  HondaCivicForum.com > General Automotive > Mechanical Problems & Technical Chat
Reload this Page >

98' DX idle surge random misfire iacv? ficv?

Mechanical Problems & Technical Chat If you've got a problem you just can't figure out, a noise you can't diagnose, or a check engine light that won't go away, ask about it here!

98' DX idle surge random misfire iacv? ficv?

Reply

 
 
 
  #1  
Old 12-18-2014, 12:14 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 6
Default 98' DX idle surge random misfire iacv? ficv?

recently bought older civic 180k,
recent shop tune-up w/timing, belts chged.

P0304, but one instance of P0300, 0301, 0302 each too.
trying DIY, cleaned IACV... apparently no EGR w/ DX.

started fine afterward, for 5-6 min till warmed up...
then idle surge... unplugged IACV and it seemed to idle fine...

is this simple evidence to replace IACV or should I
address 'fast idle valve' somehow before ordering replacement?

Any other things to check first? or as well?
( did compression testing... 1912, 170, 185, 180)
 
Reply With Quote
  #2  
Old 12-18-2014, 04:31 PM
Recognized HCF Member
Join Date: Jun 2007
Posts: 10,023
Default

Does the car drive OK other than not idling smooth?

Check that the radiator is full (when cold). Coolant sloshing around in the engine can cause an unsteady idle.
 
Reply With Quote
  #3  
Old 12-18-2014, 06:01 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 6
Default

There's is a noticeable lack of power when the misfiring occurs
after being warmed up... so I'm not driving it until I can fix this
and looking for relatively simple DIY checks...
The car obviously not worth much but was a great runner at 38-40mpg.
Any suggestions much appreciated.
 
Reply With Quote
  #4  
Old 12-18-2014, 06:09 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 6
Default

A while ago, the coolant was low in reservoir and possibly in engine for a bit,
fixed with adding coolant and burping, maybe 3-5k miles before problem
occurred. Coolant is full in radiator when cold.
 
Reply With Quote
  #5  
Old 12-19-2014, 04:11 PM
Recognized HCF Member
Join Date: Jun 2007
Posts: 10,023
Default

If it misfires while driving, especially heavy throttle and low rpm, that is usually weak sparks-- and the spark wires are a prime culprit. Some aftermarket wires are really bad and only last a few months.
 
Reply With Quote
  #6  
Old 01-16-2015, 03:16 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Posts: 6
Default followup: 98' DX idle surge random misfire iacv? ficv?

fyi...
put in new iacv -> fixed surging idle, but not misfires...

installed OEM spark plug wires (NGK 8034 HE76),
(and new spark plugs denso(4504) PK270TT)

This fixed misfires/power loss, so car running fine! :-)

thanks for replies... appreciated

note: there was 30k miles on old plug wires
labelled "STI Spark Transfer International"
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TGriffin
Mechanical Problems & Technical Chat
0
09-29-2011 03:43 AM
jlor010
Mechanical Problems & Technical Chat
1
08-08-2010 06:21 AM
jonsaidthat
Mechanical Problems & Technical Chat
8
07-01-2010 05:48 PM
jamisonh
Mechanical Problems & Technical Chat
1
02-21-2009 10:17 AM
northwoods
Mechanical Problems & Technical Chat
0
06-15-2008 07:12 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors