New From Chicago - HondaCivicForum.com


New Member Introductions Are you new to Honda Civic Forum? WELCOME! Check in, tell us about yourself and your ride. This section is not for technical questions.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-31-2006, 06:53 PM
Thread Starter
 
Join Date: Aug 2006
Location:
Posts: 17
Default New From Chicago

Hello everyone, I'm new to the forums and to the Honda world. I have a lot of newb questions but first a little back ground. I bought a red 1991 Civic 1.5L 4 speed hatchback last fall. I bought the car from a used car dealer. My first thoughts were: One, it was cheap and Two, I figured I could save money on gas. It has rust on both rear wheel wells connecting all the way around in the back. I put 400mph airplane skin over it and it's holding for now. hehe. The A/C doesn't work and I have issues with the air vent control from defrost to heat. I tossed a good stereo in it with boom box in the back and nice set of 6" speakers in the doors. That and a Sirius radio and I'm all set (Bubbabooy). It turns out I really love this car. I tuned it up, plugs, wires, cap&rotor, O2, fuel filter, etc... I change the fron struts and the front right tie rod end. Everything is good till one day on the way to work. I was doing my normal 80/85mph on the tollway and then when off the ramp I noticed it was running rough. I was low on gas so my first thought was it picked up some crap off the bottom of the tank. I changed the fuel filter but it didn't change the condition. I starts kind of hard now like it's out of time. Like it's starting against the compression. So, my next thought is, the timing belt. I swap out the belt, both seals, waterpump, idler pulley and set the timing. No change in the condition. Car runs like it's not hitting on all four. Loss of power and poor mpg. I did notice blow back coming out of the oil filler hole. Now I'm thinking maybe it's a valve. The air blowing back out seems to be cool so, so would that make it a intake? I pulled the valve cover and adjusted the them. It does seem to run a little better but not like it used. Is it possible one of my valves are breaking down or bent. I'm looking on ebay for a 1.5 rebuilt head to swap out. Is the right way to go? Or am I barking up the wrong tree? I know I need to do a compression test but my son miss placed it and I can't find it for now. Thanks in advance.
Reply With Quote
  #2  
Old 08-31-2006, 07:50 PM
cyberx32's Avatar
HCF Member
 
Join Date: Jun 2006
Location:
Posts: 4,396
Default RE: New From Chicago

well i dont know what it could be, but just wait a little and someone here will answer your questions.
Btw welcome to this site.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New member from chicago jando426 New Member Introductions 11 09-24-2007 10:55 AM
4 New Bridgestone Turanza EL400's 205/55/16 from 06 Civic EX Chicago area Timcivic PRIVATE For Sale / Trade Classifieds 0 09-07-2006 06:00 PM
NEW ALUMINUM KOYO RADIATOR-CHICAGO,IL. whtboy97 PRIVATE For Sale / Trade Classifieds 0 08-03-2006 10:56 AM
New Member from Chicago ModifiedStock New Member Introductions 7 06-24-2006 04:22 AM
new 02-03 oem carbon fiber hood. chicago suburbs. callmeyourkiller PRIVATE For Sale / Trade Classifieds 1 08-31-2005 05:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -8. The time now is 07:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.