Engine & Internal Chat about beefing up your engine's insides here.

EM1 civic, Distributor/wires problem

  #1  
Old 12-27-2007, 10:36 AM
Thread Starter
Join Date: Dec 2007
Location:
Posts: 22
Default EM1 civic, Distributor/wires problem

i got a problem with i guess distributor, the car kinda twitches(jerks) from 1-3k RPM doesn't pull smoothly, i already changed the distributor cap and the rotor, sparks plugs, the only thing thats still not changed are wires, i was thinking maybe the ignition is off or something, if anyone can give any advice, or anyone had this problem. Help would be appreciated.
 
  #2  
Old 12-27-2007, 01:13 PM
HCF Member
Join Date: Jun 2007
Location: Los Angeles, CA
Posts: 267
Default RE: EM1 civic, Distributor/wires problem

When did this problem start? Did you make any mods or perform any maintenance beforehand?
 
  #3  
Old 12-28-2007, 08:54 PM
Thread Starter
Join Date: Dec 2007
Location:
Posts: 22
Default RE: EM1 civic, Distributor/wires problem

no the car is bone stock, i bought it two months ago, has 110000KM original one owner, it was already doing it, so i changed sparks, it started doing it less, than changed distributor cap, no difference
 
  #4  
Old 12-28-2007, 09:07 PM
HCF Member
Join Date: Jun 2007
Location: Los Angeles, CA
Posts: 267
Default RE: EM1 civic, Distributor/wires problem

I'd agree with you about the ignition. I'd check the timing next. If that's in order, get some seafoam from your local auto store and run it through your system (1/3 fuel tank, 1/3 engine oil, 1/3 vacuum hose). If that doesn't work, I'd try replacing your o2 sensor next. Even if that works, the seafoam might loosen carbon deposits from your engine and leave them on your o2 sensor, so you might want to replace it anyways...or just remove your o2 sensor while you seafoam.

It'd also help if you could describe your problem in more detail.
 
  #5  
Old 12-28-2007, 09:59 PM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default RE: EM1 civic, Distributor/wires problem


ORIGINAL: 2KCIVICSIG
i got a problem with i guess distributor, the car kinda twitches(jerks) from 1-3k RPM doesn't pull smoothly, i already changed the distributor cap and the rotor, sparks plugs, the only thing thats still not changed are wires, i was thinking maybe the ignition is off or something, if anyone can give any advice, or anyone had this problem. Help would be appreciated.
Is the Check Engine Light ON?

The pictures detail how to set the timing.

You might also want to consider potential problems with the plug wires, the distributor coil or ICM, the fuel filter, and the fuel pump.





 
  #6  
Old 12-30-2007, 11:30 AM
Join Date: Sep 2005
Location:
Posts: 680
Default RE: EM1 civic, Distributor/wires problem

when was the last time the plugs were changed? and are they are the right gap
 
  #7  
Old 01-01-2008, 04:47 PM
Thread Starter
Join Date: Dec 2007
Location:
Posts: 22
Default RE: EM1 civic, Distributor/wires problem

spark plugs were changed like a month ago and yes the gap is right, they're oem spark plugs
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
itgrowsind
PRIVATE For Sale / Trade Classifieds
0
01-17-2010 11:30 PM
Mister V
Mechanical Problems & Technical Chat
1
08-22-2007 05:16 AM
addy79
ECU Tuning & Fuel Management
8
01-26-2005 06:41 PM


Thread Tools
Search this Thread
Quick Reply: EM1 civic, Distributor/wires problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.