Engine & Internal Chat about beefing up your engine's insides here.

Heavy White Smoke with a side of Missing.

  #1  
Old 07-01-2009, 06:40 PM
HCF Member
Thread Starter
Join Date: Apr 2009
Location: Nassau, Bahamas
Posts: 183
Default Heavy White Smoke with a side of Missing.

Hey guys.
Need help with this one.
Now that I finally changed the IACV, MAP sensor and TPS the car is starting and idling as it is supposed to but......yeah there's a but.
The car has a slight miss and heavy white smoke coming out of the exhaust.
I pulled each plug wire to see if there was any problems at any of the cylinders but everything seems okay. So...what can be the problem.
I'm about to blow this dam car up. It's frustrating. My brother is saying it may be valve seals. HEEEELLLLPPPP PLEASE!!!!!!
 
  #2  
Old 07-01-2009, 07:33 PM
riceburner700's Avatar
Recognized HCF Member
Join Date: Jan 2005
Location: Loveland CO
Posts: 6,629
Default

white smoke is coolant
 
  #3  
Old 07-01-2009, 07:37 PM
trustdestruction's Avatar
Moderator
Join Date: May 2007
Location: FL
Posts: 11,417
Default

There goes the head gasket
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
allisaurusrex19
Mechanical Problems & Technical Chat
1
05-21-2013 08:34 PM
uk civhead
Mechanical Problems & Technical Chat
18
01-09-2006 06:20 PM
titoe
Mechanical Problems & Technical Chat
5
04-28-2005 02:11 PM
titoe
Mechanical Problems & Technical Chat
9
04-26-2005 09:17 PM
niteryder
Mechanical Problems & Technical Chat
6
05-29-2004 11:35 PM


Thread Tools
Search this Thread
Quick Reply: Heavy White Smoke with a side of Missing.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.