Engine & Internal Chat about beefing up your engine's insides here.

quick question

  #1  
Old 05-30-2006, 01:04 PM
HCF Member
Thread Starter
Join Date: Dec 2005
Location: Carmi,Illinois
Posts: 1,707
Default quick question

I just got my engine back together.It idles fine,So i take it on a little drive less then a mile and the oil light flashes and the engine makes a little noise so I cut it off for awhile idle for a long time no problem it only does it when driving or if I rev it up over 2,000.Wouldnt the oil pump and bearings do this all the time.I am going to test the oil pressure sending unit.What does it sound like to you.
 
  #2  
Old 05-30-2006, 01:18 PM
HCF Member
Join Date: Mar 2005
Location:
Posts: 7,702
Default RE: quick question

need more info. what did you do when you tore it apart?
 
  #3  
Old 05-30-2006, 01:38 PM
HCF Member
Thread Starter
Join Date: Dec 2005
Location: Carmi,Illinois
Posts: 1,707
Default RE: quick question

Head gasket
 
  #4  
Old 05-31-2006, 08:41 AM
HCF Member
Thread Starter
Join Date: Dec 2005
Location: Carmi,Illinois
Posts: 1,707
Default RE: quick question

I am going to remove the oil pan and the oil pick up tube and screen.I will clean inspect other parts if ok,Replace gaskets and oil pressure sending unit.Then I am going to change oil in filter to 20w50 also I will add a can of engine restore.
 
  #5  
Old 05-31-2006, 09:05 PM
HCF Member
Join Date: Jun 2004
Posts: 7,699
Default RE: quick question

make sure that pickup isnt going to loosen at all. if those nuts come loose, youll lose pressure and toast the motor.
 
  #6  
Old 05-31-2006, 11:10 PM
riceburner700's Avatar
Recognized HCF Member
Join Date: Jan 2005
Location: Loveland CO
Posts: 6,629
Default RE: quick question

is there still oil in the engine? could be why the oil pressure light came on maybe?
 
  #7  
Old 06-01-2006, 07:47 AM
HCF Member
Thread Starter
Join Date: Dec 2005
Location: Carmi,Illinois
Posts: 1,707
Default RE: quick question

I checked my oil like 15 times.Its like it is getting pressure but at higher rpms it isnt like 10 psi at 1,000 rpm and around 2,500 rpms the light flickers then a light engine noise.I also want to get a gauge install so I will always know cause the light doesnt come on till 4 or 5 psi.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
THE_CRIPPLER
New Member Introductions
6
12-06-2005 08:26 AM
scottex
Mechanical Problems & Technical Chat
2
07-18-2005 04:58 PM
fastman90
Suspension, Brakes, Tires & Wheels
2
06-26-2005 12:59 PM
Smeghead009
Header, Intake, & Exhaust
1
05-31-2005 12:02 AM
02CivicEX
Header, Intake, & Exhaust
5
05-04-2005 07:03 PM


Thread Tools
Search this Thread
Quick Reply: quick question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.