Engine & Internal Chat about beefing up your engine's insides here.

99 Si Running rich...

  #1  
Old 01-13-2007, 07:34 PM
HCF Member
Thread Starter
Join Date: Apr 2006
Location: Pittsburgh
Posts: 1,091
Default 99 Si Running rich...

I was drving aroundabout an hour agoand went to go accelarate and it bogged down. I stopped and smelled the exhaust and its running rich. Its constantly bogged down even when idlingso i stopped driving and left it on the side of the road to avoid any further damage. My first guess is that the timing slipped, anyone else have any theories?
 
  #2  
Old 01-13-2007, 07:45 PM
HCF Member
Join Date: Jul 2006
Location: Jim Thorpe, PA
Posts: 557
Default RE: 99 Si Running rich...

what kinds of mods do u have? were u blowing black smoke?
 
  #3  
Old 01-13-2007, 07:54 PM
HCF Member
Thread Starter
Join Date: Apr 2006
Location: Pittsburgh
Posts: 1,091
Default RE: 99 Si Running rich...

Just an intake,clutch adn flywheel. I wasnt blowing black smoke but after it bogged down when I tried to accelarate I got a nice size cloud of white smoke. This happened on my last civic and it turned out the timing slipped along with other things. Right after the smoke I let my foot off the gas, I was still going about 30 in 3rd gear and it stalled. Not like a bad shifting stall just shut down and coast stall.


edit: it doesnt blow smoke at idle
 
  #4  
Old 01-16-2007, 09:26 PM
Senior Member
Join Date: Jan 2005
Location:
Posts: 735
Default RE: 99 Si Running rich...

it could be a timing problem, thats probably a good place to start.
 
  #5  
Old 01-16-2007, 10:20 PM
HCF Member
Join Date: Feb 2005
Location: Jersey
Posts: 7,168
Default RE: 99 Si Running rich...

How much white smoke are we talking? White smoke means youre burning coolant.......Did the car overheat? Anything unusual under the hood? Blown coolant lines? No coolant? Pull a plug and see if its white....or maybe just messed up.
 
  #6  
Old 01-16-2007, 10:58 PM
HCF Member
Join Date: Oct 2005
Location:
Posts: 92
Default RE: 99 Si Running rich...

i also have a 99 si the carwould bog down i lost almost all my power b.c i was burning coolent but there was no white smoke really the exhaust just had a sweet smell the only cl i had was a cylinder misfire so after going therw a full tank of gas in 2 days driving normaly i just pulled my motor and rebuilt now im almost done .
 
  #7  
Old 01-17-2007, 10:09 AM
HCF Member
Thread Starter
Join Date: Apr 2006
Location: Pittsburgh
Posts: 1,091
Default RE: 99 Si Running rich...

Its fixed I had a bad O2 sensor. Turns out it wasnt burning coolant
 
  #8  
Old 01-17-2007, 10:30 AM
FlipHKD720's Avatar
HCF Member
Join Date: Mar 2006
Location: Marquette, MI
Posts: 8,442
Default RE: 99 Si Running rich...

seems like quite the problem for just an o2 sensor....which one was it?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
larsenracing
Mechanical Problems & Technical Chat
25
04-24-2008 04:48 AM
scottdh20
Mechanical Problems & Technical Chat
9
11-24-2007 07:50 PM
smokingemcee
Mechanical Problems & Technical Chat
15
02-25-2006 10:20 PM
JDMracer00
Mechanical Problems & Technical Chat
2
07-06-2005 04:11 PM
AnakinKenobe
Engine & Internal
18
04-23-2005 07:07 PM


Thread Tools
Search this Thread
Quick Reply: 99 Si Running rich...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.