Engine & Internal Chat about beefing up your engine's insides here.

everything is going wrong!

  #1  
Old 07-10-2006, 09:05 PM
HCF Member
Thread Starter
Join Date: Feb 2006
Location:
Posts: 478
Default everything is going wrong!

I have been having this problem for about 2 weeks.... my BRAKE indcator stays on when i am driving, even when my parking brake is down, my Right headlight doesnt work unless iturn sharpy, and my right turn signal light is staying on in my car (not blinking), and outside it is normal. When my headlights are on my AC refuses to work. and this is a 2005 Civic! What could be wrong? I had it checked by a professonal and he said i need to replace my battery and alternator but thats almost a $400.00 right off the bat! GRRRRR!
 
  #2  
Old 07-10-2006, 09:22 PM
HCF Member
Join Date: Jun 2005
Location: Bay Area, Cali
Posts: 729
Default RE: everything is going wrong!

indcator stays on when i am driving, even when my parking brake is down
Check fluid 1st...Then it may be indicating that your brake pads are worn and need replacement.
Right headlight doesnt work unless iturn sharpy
Check for loose plug or a pinched wire..this will be a fun one to find.[:@]
right turn signal light is staying on in my car (not blinking), and outside it is normal
LOL...uhm....relay may be the cause of this...gonna have fun with this one too.[:'(][:@]
headlights are on my AC refuses to work
WTF has been going on with your ride dude?...LOL I'm guessing the battery is not holding...or power output (alt) is not allowing both to work, but I'd think it would outright kill the engine if either where that weak. Do you have issues with the car not starting? Do you trust this "professonal"??? or is he making money off of you?
 
  #3  
Old 07-10-2006, 11:43 PM
HCF Member
Join Date: Jun 2006
Location: sterling heights MI
Posts: 1,726
Default RE: everything is going wrong!

Wow electrical mess I am leaving this alone and not touching it with a ten foot pole
 
  #4  
Old 07-11-2006, 02:27 AM
HCF Member
Join Date: Jan 2005
Location: Chicago, Illinois
Posts: 5,180
Default RE: everything is going wrong!

Its an 05 and should still be under warranty, let the dealer fix it. I'd help you, but i don't feel like thinking right now.
 
  #5  
Old 07-11-2006, 10:33 AM
Senior Member
Join Date: Jul 2005
Location:
Posts: 2,501
Default RE: everything is going wrong!

Yeah what agent said, dealer... otherwise you are gonna have LOADS of fun trying to fix the problem yourself. You could have a crossed wire on your relay box, a pin on your turnsignal or headlight could be missing or not connecting properly... Lots of stuff to check through...

Let the dealer fix it.
 
  #6  
Old 07-17-2006, 11:32 PM
HCF Member
Thread Starter
Join Date: Feb 2006
Location:
Posts: 478
Default RE: everything is going wrong!

My Honda dealership will not support the warranty because i moved out of the lower 48 and went to Alaska without notifiying the dealership first. The place i went to is a Les Shwab and yes he is making oney off of me. Could it be that my Alternator like over powered itself and short out some wires? i found a Alt but its 300.00....and with a new baby its hard to have someone else fix it and there isnt a Honda dealership around....i live in the middle of nowhere...i guess im stuck.[:@]
 
  #7  
Old 07-19-2006, 02:22 AM
HCF Member
Join Date: Jan 2005
Location:
Posts: 1,010
Default RE: everything is going wrong!

first , go start your car, then pull off the positive battery clamp, does it stasy running??? alternator is good then. all your issues appear to be lighting so all you need to check is the lighting wiring, keep this in mind, almost 90 % of electrical problems, its a bad ground somewhere, follow your headlight harness to where it grounds and check that first.
 
  #8  
Old 07-19-2006, 03:40 AM
Join Date: May 2006
Posts: 17
Default RE: everything is going wrong!

what city in alaska?? if you're in anchorage i may help cuz i'm moving back there in about 2 weeks
 
  #9  
Old 07-22-2006, 04:20 PM
HCF Member
Thread Starter
Join Date: Feb 2006
Location:
Posts: 478
Default RE: everything is going wrong!

*UPDATE*
ok this is what i did, i started my car then took the + (red) battery clamp and it stayed on... so then i turned my parkinglights
on and my gauges dimmed very very low almost black but my egine stayed on. noeffect....then i turned the high beams on and my high beams and she died....is my ground at my high beams? how do i fix it?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
flinteastwood
Mechanical Problems & Technical Chat
7
05-10-2011 02:43 AM
blkwidow
Nitrous, Super Chargers, & Turbos
11
07-27-2006 03:03 PM
percious
PRIVATE For Sale / Trade Classifieds
8
11-10-2005 08:01 PM
S240161
PRIVATE For Sale / Trade Classifieds
0
07-28-2005 03:36 PM
INJENalltheway
Nitrous, Super Chargers, & Turbos
27
02-24-2005 11:15 PM


Thread Tools
Search this Thread
Quick Reply: everything is going wrong!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.