Engine & Internal Chat about beefing up your engine's insides here.

Help engine runs bad

  #1  
Old 01-11-2012, 11:46 AM
Junior Member
Thread Starter
Join Date: Dec 2011
Posts: 9
Default Help engine runs bad

my 93 civic dx D15B7 is running bad when left at idle for a long period, and smokes white, but it will not run bad on a cold start and no white smoke. i first thouggt this to be a head gasket but it only smokes after 20 min of warm idle. suggestions please
 
  #2  
Old 01-11-2012, 12:59 PM
cvcrcr99's Avatar
Moderator
Join Date: Aug 2007
Location: DUB Caeser
Posts: 7,164
Default

Any CELs? Any loss of coolant? Any oil mixing with coolant and vice versa? Any overheating? Have you done a compression check?
 
  #3  
Old 01-11-2012, 02:18 PM
Junior Member
Thread Starter
Join Date: Dec 2011
Posts: 9
Default

no milky oil or coolant
 
  #4  
Old 01-11-2012, 02:26 PM
Junior Member
Thread Starter
Join Date: Dec 2011
Posts: 9
Default

pulled out plugs
 
Attached Thumbnails Help engine runs bad-imag0176_new.jpg   Help engine runs bad-imag0178_new.jpg   Help engine runs bad-imag0180_new.jpg   Help engine runs bad-imag0182_new.jpg  
  #5  
Old 01-13-2012, 02:24 PM
HCF Member
Join Date: Jan 2012
Location: Austin, TX
Posts: 105
Default

white smoke usually means coolant if i recall correctly, so it has to be getting into the cylinder somehow.

that said, the second pic looks really lean but could be the flash, and the fourth pic looks a bit lean on the very tip, is all I see there.
 
  #6  
Old 01-13-2012, 06:35 PM
RonJ's Avatar
Recognized HCF Member
Join Date: Sep 2007
Location: Houston, Texas
Posts: 9,453
Default

Sounds like a blown head gasket to me.
 
  #7  
Old 01-16-2012, 04:06 PM
Junior Member
Join Date: Jan 2012
Location: Beaumont, Texas
Posts: 9
Default

I was having the exact same problem with my 88 DX D15, white smoke was pouring out of the exhaust like crazy and idled like crap. Problem was my head gasket, it was letting water pour in on the left side of the block into a spark plug.
 
  #8  
Old 01-17-2012, 09:27 AM
Junior Member
Thread Starter
Join Date: Dec 2011
Posts: 9
Default

My friend who is a mechanic said my gasket and head are fine, it is the cts causing the ecu to not deliver fuel properly, as per the white smoke, no ideas but pressure tests passed.
 
  #9  
Old 01-19-2012, 10:07 AM
HCF Member
Join Date: Jan 2012
Location: Austin, TX
Posts: 105
Default

Originally Posted by puckman1325 View Post
My friend who is a mechanic said my gasket and head are fine, it is the cts causing the ecu to not deliver fuel properly, as per the white smoke, no ideas but pressure tests passed.
Did your friend have any evidence other than a 'pressure test' to say it was fine? What 'pressure' did they test? Cylinder compression? I've seen head gaskets blow and not affect compression enough to cause running issues, but will still pour coolant into one (or more) cylinder(s) like a faucet.
 
  #10  
Old 01-19-2012, 01:28 PM
cvcrcr99's Avatar
Moderator
Join Date: Aug 2007
Location: DUB Caeser
Posts: 7,164
Default

White smoke = coolant
Blue smoke = oil
Black smoke = fuel

/story. I agree with Ron. Sounds like a blown HG
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rics94 civic
ECU Tuning & Fuel Management
3
11-07-2008 01:53 PM
skibum853
Mechanical Problems & Technical Chat
0
11-18-2007 09:40 AM
ErikElvis
Mechanical Problems & Technical Chat
8
03-20-2007 02:52 PM
Gernie
Mechanical Problems & Technical Chat
5
02-15-2007 11:25 PM
coupe
Engine & Internal
4
12-06-2006 10:37 PM


Thread Tools
Search this Thread
Quick Reply: Help engine runs bad


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.