Engine & Internal Chat about beefing up your engine's insides here.

HELP PLEASE

  #1  
Old 10-26-2006, 08:31 PM
Thread Starter
Join Date: May 2006
Location:
Posts: 976
Default HELP PLEASE

Ok guys, i got the new injectors in today, and tried to crank her up. No go. I wanted to cry. The only good thing is i dont have gas spilling out the exhaust side of the turbo. So, here is the deal, the engine cranks over and when i put the gas to the floor, it kinda sputters like it really wants to start, but as soon i stop hitting the ignition button, it dies. Im at a total loss, and i dont know if my brainstorming is off the wall, or there may be somthing to it. SO, im going to throw a few things out there, let me know if any sound legit.

1. To big spark plug gap-running vitara pistons with .30 gap
2. Wires are shot (not plugs, i just put the new ones in)
3. Cap and rotor-looking at possible MSD coil and cap
4. Unknown Vector

Any suggestions would help guys, im ready to just give up, but ive come this far, so i want to see my time, money, blood, and sweat pay off.
 
  #2  
Old 10-26-2006, 09:39 PM
StifflersMom's Avatar
Cat Fuсker
Join Date: Nov 1978
Location: The Moon
Posts: 6,804
Default RE: HELP PLEASE

do you have fuel pressure? Check if you actually have spark in all cylinders, make sure your wires are going to the correct cylinders....you know, the basics. To me if you have spark and fuel it sounds like timing or firing order.
 
  #3  
Old 10-26-2006, 11:03 PM
Thread Starter
Join Date: May 2006
Location:
Posts: 976
Default RE: HELP PLEASE

Ok, i post on D-series.org as well, and some people are telling me my timing(sp) is 180 degrees off. Does this sound like it could be the culprit? I know for a fact that the block was at tdc due to the head being off, i could line it up using the marker and seeing the piston. The head though, i would have put money that it was at tdc, but with the replies ive been getting, im starting to get worried. IF this is the problem, what would be the easiest way to test/fix it?
 
  #4  
Old 10-27-2006, 08:46 AM
StifflersMom's Avatar
Cat Fuсker
Join Date: Nov 1978
Location: The Moon
Posts: 6,804
Default RE: HELP PLEASE

timing being 180* off is definitly a possibility. you'll just have to redo the timing.
 
  #5  
Old 10-27-2006, 09:19 AM
Thread Starter
Join Date: May 2006
Location:
Posts: 976
Default RE: HELP PLEASE

ok, this is going to sound stupid. I can rebuild a damn motor, but get confused when it comes to the timing issue. Are you talking about 180* on the cam? or the distributor? Like, do i have to take off the belt and rotate the cam 180 OR rotate the distributor 180? If it is the distributor, how do i rotate it 180 and still get it to fit? Wont it only slip into the end of the cam one way because of the notch? I know i sound retarted, but at this point i really dont care, i just want my car
 
  #6  
Old 10-27-2006, 10:06 AM
HCF Member
Join Date: Aug 2006
Location:
Posts: 1,479
Default RE: HELP PLEASE

Everybody has a right for a temporary lapse of reason
You did a great job, man, just a bit more to go Take your textbook and find the chapter about timing belt replacement. Start from scratch and make sure your camshaft is in sync with your crankshaft. And distributor can fit only one way, you can't have it wrong here
 
  #7  
Old 10-27-2006, 10:14 AM
HCF Member
Join Date: Oct 2005
Location:
Posts: 4,371
Default RE: HELP PLEASE

that's a pretty clean looking setup you got there. good luck.
 
  #8  
Old 10-27-2006, 02:21 PM
Thread Starter
Join Date: May 2006
Location:
Posts: 976
Default RE: HELP PLEASE

thats just it though, i know i had it right because when i took off the head, i had the #1 cylinder at TDC, and on the head, the intake valves were just opening for the intake stroke on the #3 cylinder. So when i put the head back on, again the block was at TDC, and i reinstalled the cam, and cranked it around till it came to rest on the intake for cylinder #3. So when people are saying 180 off, are they talking about ignition?
 
  #9  
Old 10-27-2006, 05:27 PM
Join Date: Sep 2005
Location:
Posts: 680
Default RE: HELP PLEASE

what kinda injectors are they?
if you got dsm's then you prolly need a resistor box
 
  #10  
Old 10-28-2006, 12:35 AM
Thread Starter
Join Date: May 2006
Location:
Posts: 976
Default RE: HELP PLEASE

they are stock d16z6. All i want to know is what is meant by timing is 180 off?? Also, could this scenario be a possibility:
When the car was parked it was on empty, and it has been sitting for 2 months. Could moisture have built up, or maybe the gas broke down?a
 

Thread Tools
Search this Thread
Quick Reply: HELP PLEASE


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.