Engine & Internal Chat about beefing up your engine's insides here.

ULTIMATE B16A ENGINE PROBLEM PLZ HELP

  #1  
Old 06-28-2007, 05:21 AM
Thread Starter
Join Date: Jun 2007
Posts: 1
Default ULTIMATE B16A ENGINE PROBLEM PLZ HELP

ok here is the run down...
i have a 96 civic ek, i did an engine swap and put in a b16a4 with the corresponding ecu.
now my problem is that when the car is cold it will idle at about 1200rpm, as i drive along as i start slowing down to stop when i put the clutch it the idle goes up to 2000rpm or higher then once the car is completely stoped it will slowly drop to around 1500rpm. it will keep doing this even after the car has warmed up.
i hav found that once the car has warmed right up if i turn the car off then back on it will run fine.
can anyone plz help me figure out what the cause of this problem is
things that have been checked:
*throttle body
*vaccume leaks
*iacv
*ecu
if u can help me fix this problem i will forever be ur servent
HELP ME ITS DRIVIN ME CRAZY!!
 
  #2  
Old 07-18-2007, 06:12 PM
HCF Member
Join Date: Jun 2007
Location: Los Angeles, CA
Posts: 267
Default RE: ULTIMATE B16A ENGINE PROBLEM PLZ HELP

have you tried checking your throttle cable locknut? that probably should've been done with the throttle body inspection, but just in case it wasn't. I had a similar problem with my civic and it was the locknut getting jammed when I was driving.
 
  #3  
Old 07-18-2007, 06:14 PM
Mr Mobsta Man's Avatar
HCF Member
Join Date: Jun 2006
Location: West Virginia
Posts: 3,086
Default RE: ULTIMATE B16A ENGINE PROBLEM PLZ HELP

have you tried cleaning your iacv?
 
  #4  
Old 07-18-2007, 06:17 PM
Member
Join Date: Jul 2007
Posts: 162
Default RE: ULTIMATE B16A ENGINE PROBLEM PLZ HELP

ORIGINAL: carlitos

ok here is the run down...
i have a 96 civic ek, i did an engine swap and put in a b16a4 with the corresponding ecu.
now my problem is that when the car is cold it will idle at about 1200rpm, as i drive along as i start slowing down to stop when i put the clutch it the idle goes up to 2000rpm or higher then once the car is completely stoped it will slowly drop to around 1500rpm. it will keep doing this even after the car has warmed up.
i hav found that once the car has warmed right up if i turn the car off then back on it will run fine.
can anyone plz help me figure out what the cause of this problem is
things that have been checked:
*throttle body
*vaccume leaks
*iacv
*ecu
if u can help me fix this problem i will forever be ur servent
HELP ME ITS DRIVIN ME CRAZY!!
What do you mean by "checking"? Visual inspections aren't the best way to rule something out. Clean your IACV out.

And what is this mysterious b16a4? I've never heard of this engine, and I've been around Hondas for over 4 years.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cadman421
EK Swaps
5
05-11-2007 12:47 AM
that_guy5
Mechanical Problems & Technical Chat
11
02-09-2007 08:09 AM
Fiirkan
Pics and Videos
5
08-23-2006 12:21 PM
papi
Suspension, Brakes, Tires & Wheels
5
05-18-2005 09:27 AM
nitsuj1604
Inside and Out
6
06-02-2004 06:32 AM


Thread Tools
Search this Thread
Quick Reply: ULTIMATE B16A ENGINE PROBLEM PLZ HELP


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.