Mechanical Problems & Technical Chat If you've got a problem you just can't figure out, a noise you can't diagnose, or a check engine light that won't go away, ask about it here!

1994 Civic Main relay /ECM issues

  #1  
Old 05-21-2011, 07:05 PM
Junior Member
Thread Starter
Join Date: May 2011
Location: North Jersey, The sticks
Posts: 3
Unhappy 1994 Civic Main relay /ECM issues

Hi Guys, I am new as a member but the forum helped me through many of my other problems, till now. I been having issues with the main relay, the CEL will not go off, the main relay wont advance the fuel pump 2sec prime. I traced it down to the ground coming from the ECM on pin 8 of the main relay harness. However if I let the car sit for, lets say 7 minutes with the key on, the Main relay clicks on and everything is normal. Now this issue seems more likely to show its face when its damp or rainy, and more frequent since Easter. I am out of ideas, is the ECM really bad or am I missing something else? Does Pin 8 leave the main relay and go directly to the ECM or does it go through something else. If anyone could give me a hand I would appreciate it, THANKS!
 

Last edited by grizzlypower2001; 05-21-2011 at 07:09 PM.
  #2  
Old 05-22-2011, 06:40 PM
Junior Member
Thread Starter
Join Date: May 2011
Location: North Jersey, The sticks
Posts: 3
Default

Does anyone know if I can run a seperate ground to the main relay and disconnect the ECM controlled ground( pin #8)? Any help I could really use, Thanks.
 
  #3  
Old 06-01-2011, 12:58 PM
Junior Member
Thread Starter
Join Date: May 2011
Location: North Jersey, The sticks
Posts: 3
Cool Fixed for now

I don't know if I can receive any responses, but I didn't get any help. I did get 63 views. Is there something I did wrong or nobody has any input?

However I said F' it and ordered a used ECM and it fixed the problem. Thanks to anyone if they tried to respond and couldn't. I may not have did my posting correct.
 
  #4  
Old 08-21-2013, 05:03 AM
Junior Member
Join Date: Aug 2013
Location: SoCal
Posts: 3
Smile Your Problem & Self Fix Appreciated

Thanks Grizzly for sharing your problem and fix, it is always useful for others who are reading these posts trying to piece together their problems. That's great your ECM was the problem, congrats! I know this is an old thread, but it helped me so I thought to share. I'm trouble shooting hard start during hot weather (above 80f). I'm going to test the Main Relay today. Most of what I learn is from ETCG (Eric the Car Guy). But posts like yours are very helpful too.
 
  #5  
Old 08-21-2013, 05:38 AM
Recognized HCF Member
Join Date: Jun 2007
Posts: 10,023
Default

The first step is always to take the main relay out and resolder it. Don't bother testing anything, just do it, as that alone will fix about 95% of these "cranks but won't start when hot" cases (on 1988 to 1995 models). If the problem persists, then you check deeper. Faulty ECUs are rare, but they do happen. The relay though is a known lemon part as they shipped from the factory with an inadequate solder job.

Write-ups like this are all over the web, but if you haven't seen one yet here's our version, which I think is quite well done:
https://www.hondacivicforum.com/foru...-repair-89522/
 

Last edited by mk378; 08-21-2013 at 05:47 AM.
  #6  
Old 08-21-2013, 05:54 AM
Junior Member
Join Date: Aug 2013
Location: SoCal
Posts: 3
Default Advice on Buying Soldering Iron

Thanks for your helpful insights and the confirmation Mk. Yesterday I watched a Youtube video for Main Relay Soldering by ScannderDanner & ETCG as it really sounded like my problem...I know nothing about electronics so just about everything I read regarding these relays and switches and their symptoms and fixes really helps. You are right, the fix is really simple as long as I can identify the cracks and solder it properly
If you, or anyone, can share any advice on buying a soldering iron (watts/temp/tips/mfgr) I would be most grateful. Thanks again!
 
  #7  
Old 08-21-2013, 06:30 AM
Junior Member
Join Date: Aug 2013
Location: SoCal
Posts: 3
Default

Thanks for the link, I overlooked it the first reading. This is my first day here, feeling a bit geeky. I did find Main Relay Fix, Troubleshooting (Honda, Acura) and how to solder which also helped answer my questions. This is a great site, thanks for your awesome contributions!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ktorres1120
Mechanical Problems & Technical Chat
7
09-04-2013 08:07 PM
zwj1021
Mechanical Problems & Technical Chat
5
08-07-2008 07:36 PM
budman177777
Mechanical Problems & Technical Chat
3
03-02-2008 05:47 PM
danielintheuk
Mechanical Problems & Technical Chat
3
09-17-2006 01:30 AM
djstreet
Mechanical Problems & Technical Chat
0
04-06-2006 08:43 PM


Thread Tools
Search this Thread
Quick Reply: 1994 Civic Main relay /ECM issues


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.