Mechanical Problems & Technical Chat If you've got a problem you just can't figure out, a noise you can't diagnose, or a check engine light that won't go away, ask about it here!

Ecu/Electrics problem?

  #1  
Old 06-27-2019, 01:36 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 2
Default Ecu/Electrics problem?

I went to change injectors on my b16a2 swapped 1998 ej6and now the car wont start. Same thing happened yesterday when I unplugged a sensor when I plugged it back in it would not start again, so I left it and next morning started up fine. Now when i replaced the injectors same thing happeneing, I turn the key but fuel pump wont prime car does turn over, I checked the relay and grounds all good. I then went to inspect the ecu and found that when I had the ignition turned on and removed the small c plug from the ecu the pump would then prime? Seems very weird to me I i tried a different ecu and same thing was happening I have no idea what the problem is, any help I would graetly appreciate.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jonnyk
Mechanical Problems & Technical Chat
3
12-06-2011 01:12 PM
Q336814
Mechanical Problems & Technical Chat
3
10-20-2010 07:05 AM
duffa66
Mechanical Problems & Technical Chat
1
04-29-2007 09:26 AM
civics101
ECU Tuning & Fuel Management
1
04-14-2007 10:04 PM
ricerocket
ECU Tuning & Fuel Management
0
05-13-2005 09:19 AM


Thread Tools
Search this Thread
Quick Reply: Ecu/Electrics problem?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.