ECU Tuning & Fuel Management Discuss electronics and related components within.

No Fuel ECU?

  #11  
Old 09-03-2009, 12:38 PM
Junior Member
Thread Starter
Join Date: Aug 2009
Posts: 13
Default

Also I want to say the manual listed I believe the A7 and A8 pins for this #8 Main relay pin but there is only the A7 and no wire for A8. The car wiring is not chopped up and was running so I don't think it was removed, I just think it was never there.

I looked at het ECU pinout sticky at the top of this forum and found this is correct. No wire at the A8 pin
 

Last edited by teqmod; 09-03-2009 at 01:21 PM.
  #12  
Old 09-03-2009, 02:29 PM
Junior Member
Thread Starter
Join Date: Aug 2009
Posts: 13
Default

OK, I pulled the codes from the car.
Code 15 IGN. output signal
Code 19 Auto Trans Lockup
Code 41 O2 sensor heater

I believe the code 15 to be my issue for this possibly. Of course on the net I have only found people saying faulty distributor, replace it. I have spark but I guess this could still be the issue if the ECU is not seeing a signal from the dist. Time to research this code a little more.
 
  #13  
Old 09-03-2009, 04:25 PM
Junior Member
Thread Starter
Join Date: Aug 2009
Posts: 13
Default Problem Resolved

Thanks for everyones help.

After getting the codes and checking around I wanted to verify this was the issue. I pulled the back-up fuse to reset the codes and checked for codes again without cranking to verify they were cleared. I then tried to start the vehicle and cranked for a minimum of 20 seconds. I then checked codes again and there were none. My assumption is that in all my checking I inadvertently tripped these codes which is what I was afraid of. So after scratching my head for a while and feeling beat I just started putting the interior back together a bit. I then saw my test Main relay laying on the floor. I went ahead and plugged it in again and tried it. The car then started. I don't know why now and not before but it is now running. I think maybe since I cleaned the grounds at the thermostat? Bad ground burned up the main relay? Who knows but it is running now so thanks for everyones help on this.

I also recently picked up a 97 civic 1.6 which I am going to keep as a daily driver so I am going to try to keep up on this board, help if I can and I am sure there will be more questions in the future!!
 
  #14  
Old 04-11-2014, 03:35 PM
Junior Member
Join Date: Apr 2014
Posts: 3
Default

Originally Posted by teqmod View Post
OK sorry for the delay I have been out of town but started working on this a bit yesterday and will do some more today. I took the ECU for an hour drive yesterday and plugged it in a buddys 95 civic and his car ran off it with no issues. I have a P06 ECU and his was a P28 or something to that effect but it ran just fine.

I came home plugged it back in and still nothing. I undid the grounds at the thermostat and cleaned the contacts, nothing. I began to recheck the system and came to the point where the ECU is not providing a ground to the Main relay on pin 8 of the relay ( I checked this at the ECU but do not remember the pin off the top of my head.) The battery is a little weak now but I was getting about 3v on the wire. I saw in the diagram the resistor internal to the relay but if there is no ground it does not matter what the positive voltage is. From my understanding the ECU should provide a ground for a couple seconds when the key is switched to the on position. I am not getting this.

I still have not checked codes as I was running out of time and since I had a running car to test the ECU on I figured I would do that first. The next thing I guess I need to figure out is what the ECU is looking for to activate the fuel pump. Hopefully the codes will help provide this. I also am going to ground the #8 pin and see if the car runs that way as well.


P06 ECU
A25 and B1 they are interconnected inside the ECU and you should find 12 positive volts wen you open the key,
D1 full time 12 positive volts,
and some of these pins A23,A24 and A26 logic ground are interconnected inside the ECU
B2 is a logic ground and isn't interconnected with any other pin inside the ECU,
ECU chassis do not supply ground to the circuit board and is not connected on any way to it,
All four ground wires A23,A24,A26 and B2 run from the ECU to the junction ground bolt at the thermostat housing and you shouldn't have a lot of resistance between the battery negative and these pins
Use common sense...
If you're testing for positive your ground is the negative terminal of the battery and if you're testing for negative your power is gonna be the positive of the battery...
You can check for continuity between a23 a24 a26 and b2 or if you checking for resistance clamp one probe to the battery negative and use the other probe with a23 a24 a26 b2..
Make sure the connectors are getting good contact with the pins of the ECU
 
  #15  
Old 04-06-2019, 07:56 AM
Junior Member
Join Date: Apr 2019
Posts: 2
Default

I have a 98 civic with a no crank no start problem, I've done all the tests and checked everything I could. The battery is good the starter seems to be in order, but I have no fuel pump when I hit the key. (It will run if I jump terminals 1-7 or 5-7 on the main relay) I already replaced that relay and still nothing. A scan tool won't link to the car either. I got no idea what to do.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Civic maniac
ECU Tuning & Fuel Management
10
11-30-2008 01:58 AM
Captain_Sl0w
ECU Tuning & Fuel Management
0
08-19-2008 06:41 PM
theShamgod
ECU Tuning & Fuel Management
1
08-15-2008 02:48 PM
xiong.s2460.mccd
Mechanical Problems & Technical Chat
7
07-19-2008 08:08 PM
civics101
ECU Tuning & Fuel Management
1
04-14-2007 10:04 PM


Thread Tools
Search this Thread
Quick Reply: No Fuel ECU?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.