'99 Civic LX occassionally sputters/jerks while accelerating - HondaCivicForum.com


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-23-2015, 05:04 AM
Junior Member
Thread Starter
 
Join Date: Dec 2012
Posts: 3
Default '99 Civic LX occassionally sputters/jerks while accelerating

As the title states, my '99 Civic LX with 190,000 miles occassionally sputters/jerks while accelerating. It first started doing it a couple months ago. It was very bad. At any RPM below 2,000 when taking off/accelerating it would barely move. It would stutter and buck. Most of the time when it was over 2,000 RPM it was fine.

I replaced the fuel filter, which I had never done in 80,000 miles. I also replaced the spark plugs, which had 30-40,000 on them. The plugs are NGK. The distributor cap, rotor, and wires have 30-40,000 miles on them.

I can hear the fuel pump prime when I turn the key before starting it. When I have below half a tank of gas it will crank longer than normal to start. If I hold the key on first to prime the pump it starts right away.

After I had replaced the fuel filter and plugs it has driven perfectly for a few weeks. Then this morning after not driving it since Friday it sputtered a couple times. Also, at idle it would occasionally feel like it was missing/sputtering a bit.

The check engine light is on, and has been for months. I had the codes read and it came back as evap/emissions. I forget the exact code. It ran perfectly for months with the light on. It could be a gas cap or the evap canister or sensor. Gas cap is cheap, the other stuff, not so much, $300 or so. That's why I never messed with it.

So, is there moisture getting in somewhere? Is the fuel pump going out? Is it something related to the CEL? Or something completely different? Thanks for the help. It's my daily driver, and my wife has needed to drive my truck since her van is having issues too. Vehicles are driving me crazy.
Reply With Quote
  #2  
Old 06-23-2015, 10:56 PM
HCF Member
 
Join Date: May 2013
Posts: 722
Default

the specific code will tell you what needs to be checked that code is very important there also could be new codes being given how would you know ??. try cleaning the intake and throttle body also check the air filter.

Last edited by itburnswhenIP; 06-23-2015 at 11:03 PM.
Reply With Quote
  #3  
Old 06-29-2015, 07:23 AM
Junior Member
Thread Starter
 
Join Date: Dec 2012
Posts: 3
Default

Last week took off the distributor cap to have a look. There was a lot of corrosion of the contacts. For now I cleaned them up with fine sandpaper. It's been running great ever since so I'll replace the cap and rotor. The air filter looks like new.

This morning I was finally able to get the CEL codes. They came up with P1457, and they list possible causes as loose fuel cap, vapor canister saturated, failed vent solenoid, failed purge solenoid.

The light has been on for a couple months, and it's the same code that it was when it first came on. I guess a cheap and easy thing would be a new gas cap. What are common causes of that code on a Civic?

Also, after he checked the code and I started the car to leave to CEL was off. Is that normal? Did it get reset and might come back? Thought it was strange.
Reply With Quote
  #4  
Old 06-29-2015, 04:20 PM
HCF Member
 
Join Date: May 2013
Posts: 722
Default

thats the one code you don't want to see because there are numerous possible causes in the EVAP system so before you start throwing money at it i would suggests you have a shop smoke test the evap for leaks in order to pinpoint the exact trouble spot.
Reply With Quote
  #5  
Old 06-30-2015, 07:10 AM
Junior Member
Thread Starter
 
Join Date: Dec 2012
Posts: 3
Default

That's what I thought after reading several posts about it. Some of the parts, if needed, aren't cheap either. So far the CEL hasn't come back on. We'll see.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
96 hatchback cx that jerks while driving civicchica25 Mechanical Problems & Technical Chat 1 05-04-2011 11:09 AM
Running perfect forever, then one night while driving, sputters, stalls, won't start J-star Mechanical Problems & Technical Chat 9 05-16-2009 06:41 AM
Car sputters and bucks when accelerating JohnAy Mechanical Problems & Technical Chat 9 10-06-2008 06:52 AM
Jerkiness while accelerating (98 Civic HX) elysian Mechanical Problems & Technical Chat 5 02-15-2006 08:09 PM
hesitation while accelerating in a 97 DX Falhawk Mechanical Problems & Technical Chat 1 07-14-2005 03:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 08:34 AM.