99 ex runs like crap after stopped at al light - HondaCivicForum.com

Go Back  HondaCivicForum.com > General Forum Information > HCF Suggestion / Forum Help Center
Reload this Page >

99 ex runs like crap after stopped at al light

HCF Suggestion / Forum Help Center This section is for suggestions and help pertaining to the forum, not for help with a car.

99 ex runs like crap after stopped at al light

  #1  
Old 08-19-2016, 03:31 PM
Junior Member
Thread Starter
Join Date: Aug 2016
Posts: 1
Default 99 ex runs like crap after stopped at al light

Ok i have 99 ex coupe y8 motor and i live in hell (Florida. summer) its hot dc sports headers short ram intake this thing has always had slight cooling issues at iddle i have changed to an all aluminum radiator new cooling fan switch i even threw on a new hg and had head shaved and that helped until it got to be 98 degrees out
If i stop at a long light i suddenly have like half the power and response. Rings maybe 206k on block any and all replies appreciated
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Chuckles'_LS
Mechanical Problems & Technical Chat
12
09-09-2009 06:16 AM
trent179
Mechanical Problems & Technical Chat
24
01-27-2008 07:18 PM
DRAGUNOV
Mechanical Problems & Technical Chat
2
08-30-2007 08:51 AM
StifflersMom
The Lounge
23
11-08-2006 10:30 AM
stylincompact
Mechanical Problems & Technical Chat
3
06-26-2006 01:31 AM


Thread Tools
Search this Thread
Quick Reply: 99 ex runs like crap after stopped at al light


Advertising
Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.